Results 1 to 9 of 9
  1. #1

    BR: Gorgon´s Alliance- Has ANYONE got LAN multiplayer to work, ever?

    Hey all,

    Been having a mind-wrecking time for the last couple of hours trying to get BR: Gorgon´s Alliance to work in multiplayer LAN.

    Was hard enough to get it to work at all, but thanks to posts in this forum we did manage to figure that part out :)

    Using a win98 emulator works, with the proper tweaks.

    We now have a fully functioning BR v1.04 on both of our computers, but the problem is it won´t find any games in the Local Area connection tab and needless to say, the Sierra online hosting service has expired ;) It just says "searching" and "choose a game" for ages, but nothing ever comes up.

    At first the issue was obvious: The win98 emulator wasn´t connected to the internet, that part is fixed now. Internet explorer works fine on it. But still, no Birthright.

    I feel completely drained having tried almost everything, and now my stubborn streak is kicking in :(

    Its the principle of the thing now, it MUST work, haha.

    In the interest of full disclosure, yes, it´s a torrent copy but i DID buy the original game all the way back in 1997ish, and I own loads of the Birthright D&D material from back in the day as well from boxed set to realm guides, so I´m certainly not unsupportive of the franchise!

    So has anyone here EVER got a multiplayer LAN game to work, either on a win98 emulator or on winxp/win7 ?

    If so, I´d love to hear how!

    I´m sure it worked back in the day with 97-era modems and routers, but I need some hope to continue the quest.

    PS: We tried the Hamachi method as well, but didn´t work.

    PPS: Please help! We need to have a massive war between Tuarhievel and Aerenwe, and possible the dwarves of Baruk-Azhik as well when the third brother arrives :)

  2. #2
    Senior Member
    Join Date
    Feb 2002
    New Haven, CT
    So to not leave you hanging any longer without an answer...


    Even back playing on my Pentium (1) with Windows 98, I never got it to go multiplayer.


  3. #3
    Sadly no, it used to hardly work back then. One of the problems with sierra as a publisher is that they tended to have a lot of this, most of their games were obvious beta, and while they had really amazing gameplay mechanics or really amazing potential a lot of the time, they were still far too buggy to be a full release.

  4. #4
    Actually, we did get it to work!

    Wasn't easy... I LITERALLY broke windows on my desk top trying to get it to work, and have had to do a complete reinstall of winxp. Not the game's fault, was just my fault messing around a little too much.

    But the good news is, for future reference, it does work. And it's not hard, once you know how.

    Im running Winxp pro. On my computer, I have Birthright installed in the normal games/sierra directory and I created a shortcut from winbr.exe which I then place in the desktop and select "compatability, win95 mode, run in 256 colors, run in 640 screen resolution, and disable visual themes. Not sure all that is required, but it helps at least, and it doesn't crash anymore. You DO need to patch to 1.04 of course, and install 1.02 and 1.03 first, in order.

    It didn't work at first, because it kept insisting there was no birhtright CD, even if I had it mounted on daemontools.

    Problem with mounting the CD image in daemontools was the Birthright only looks at the D: directory! So either burn a disc image, or change your DVD drive to another letter, and then let daemontools take over the D: slot. To find out how to do this, you can google, thats what I did.


    My little brother has windows7 on a brand new laptop. He uses a win98 emulator to get the game to run. Fine enough, as it is, but you DO need to set up the win98 emulator to recognize LAN connections. Again, you ll have to google how to do this, but it IS possible.

    Also when you select multiplayer, be sure to click the "TCP/IP" button. The "modem" selection does not work for obvious reasons. Plus, we haven't tried it with wireless, we pretty much assume that won't work. We're running a standard LAN game through a home router net work.

    And it works!

    We're on turn 17 now, and Tuarhievel is taking back its elven forests while Aerenwe is trying to rally the human southlands to its banner. It's amazing how much fun a game from 1997 can be, and really, we havent seen any game breaking bugs.

    Well, except that the gorgon kept summoning SUPER stacks of skeletons, which then turned into "chaos" skeletons. To fix that, we took away all his source holdings in the scenario editor, so he can still do this... but not right away. He is slowly building up his sources again, of course.

    Besides regents dying too often and gimping their realms, I really have no complaints about the AI!

    PS: If anyone knows how to bring dead regents back, please let me know. I don't think the scenario editor allows for this.

  5. #5
    Senior Member
    Join Date
    Mar 2006
    Tested with Hamachi if I remember well. The problem is that you can't play battle but you have only simulated battle where always win the most expensive troop.

  6. #6
    Junior Member
    Join Date
    Dec 2007
    Hi All
    I'm a total PC numpty but was wondering where I could get a Win98 emulator for use on my PC which is currently running Windows 7. I'd love to get Gorgon's Alliance up and running on my new PC rather than clunking along and crashing a lot on my ancient 98 PC.

  7. #7
    I got BR running on my computer (64bit Win 7) by using Dosbox to install it, (mount your cd drive the same as which one it would be reading from, even if its an image) and installed patch 1.4 on it. Patch 1.3 cannot be installed with dosbox and 64bit windows confuses it, so I couldn't use it.

    Now I copied br.exe and pasted a shortcut on my desktop, and it works wonderfully, even in full screen!
    Scened doesn't use the next directx, so I have to use that in windowed mode because of the nasty green stuff.

    IPX/SPX - This is an older protocol that windows has only supported but will not put up by default. Your network devices in control panel have the option to add protocol, adding this makes windows able to use this option. However, TCP/IP may still be the better option, particularly over Hamachi.

    settings for dosbox to get it started:
    Z: mount c C:\
    Z: mount <cd drive for birthright> <current drive of disk>
    (lets say this is still D
    (Program loads, find the highest resolution setting, think its L)
    (Game is installed)!
    (Copy patch exes to BIRTHRT folder)
    C:\ cd Sierra
    C:\SIERRA\ cd birthrt
    (rename it that way, it will run and you will be able to copy shortcut of BR.exe to desktop and play!)
    (If not running 64bit, try running the 1.3 patch from windows and then the 1.4 patch from either windows or dosbox. Virtualbox or other windows emulator may allow you to install the whole game, then just copy the folder and make sure your CD drive is the same)

  8. #8
    Senior Member Mirviriam's Avatar
    Join Date
    Apr 2008
    Where the moon cuts the wind.
    Used to play it all the time lan with 2 or 3 computers.

    The issue for us windows '98 & windows 2000 used to have netbios on by default. When we encounter winXP, we started enabling netbios advertisements & had no issues after that...though using emulators takes more as every has stated.

    As to the super skeleton stacks, include 4 mid level priests lieutenants & all knights.
    Legacy of Kings: Member

  9. #9
    Quote Originally Posted by blastradius14 View Post
    I got BR running on my computer (64bit Win 7) by using Dosbox to install it, (mount your cd drive the same as which one it would be reading from, even if its an image) and installed patch 1.4 on it. Patch 1.3 cannot be installed with dosbox and 64bit windows confuses it, so I couldn't use it.
    Try the patches hosted by The Sierra Help Pages. They have them available as ZIP files that you just extract into your game directory. Hope that helps.

    It definitely fixed the Bindier adventure bug I had on a save game I'd been playing idly for a while.

    The Character and Scenario editors finally worked too once I changed the drive-letter of my CD-ROM drive to the same thing I use inside DOSBox. I finally get to play around with them. It's just too bad I need the physical CD with me, since I have no portable way of mounting an ISO inside Windows.

    Edit: I've put together installation instructions for Birthright on Windows 10 including multiplayer. They're available here:

    This setup should work over VPN, but I haven't had a chance to test it.
    Last edited by Kami; 01-20-2021 at 04:38 AM. Reason: Update with instructions for installing on Windows 10.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Making Gorgon's Alliance PC Work
    By thelebk in forum The Royal Library
    Replies: 16
    Last Post: 12-22-2009, 02:07 PM
  2. Gorgon's Alliance Multiplayer
    By C Bag in forum The Royal Library
    Replies: 2
    Last Post: 12-07-2009, 08:41 AM
  3. Any Play Birthright: The Gorgon's Aliance Multiplayer?
    By XDrake in forum The Royal Library
    Replies: 10
    Last Post: 08-30-2007, 04:34 AM
  4. The Gorgon's Alliance
    By maggo550 in forum The Royal Library
    Replies: 2
    Last Post: 01-24-2004, 06:01 PM
  5. Gorgon`s Alliance
    By Birthright-L in forum The Royal Library
    Replies: 0
    Last Post: 06-12-2002, 11:19 AM

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
BIRTHRIGHT, DUNGEONS & DRAGONS, D&D, the BIRTHRIGHT logo, and the D&D logo are trademarks owned by Wizards of the Coast, Inc., a subsidiary of Hasbro, Inc., and are used by permission. ©2002-2010 Wizards of the Coast, Inc.